Tutorial de RoboFlash Toolkit 2.0 1

Tutorial de RoboFlash Toolkit 2.0

RoboFlash Toolkit es una coleccion de utilidades disefiadas para complementar el
disefio de aplicaciones Flash. Incluye las siguientes herramientas:
e RoboFlash TextAnimator: para crear animaciones de texto en Flash de
una forma rapida y facil.
¢ RoboFlash Splicer: combina varios archivos SWF, imagenes, sonidos, etc
en un solo archivo flash.
e RoboFlash Screensaver: disefia protectores de pantalla windows a partir
de archivos flash.
e RoboFlash Protector: protege la aplicaciéon SWF frente a la
descompilacion.
e RoboFlash Printer: es una impresora virtual para crear archivos SWF a
partir de cualquier archivo imprimible.
e RoboFlash Extractor: permite extraer los recursos: imagenes, sonidos,
clips de pelicula, etc, a partir de un archivo SWF
e RoboFlash Converter for PowerPoint: se utiliza para convertir una
presentaciéon Powerpoint en un archivo Flash para la web.

RoboFlash Toolkit dispone de una consola principal desde donde se pueden arrancar
todas y cada una de esta utilidades, incluido el propio programa Macromedia Flash.
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1. RoboFlash TextAnimator.

1. Doble clic en el boton RoboFlash TextAnimator en la

consola de aplicaciones.

L 2. En el cuadro Movie Properties (Propiedades de pelicula)
puedes definir la anchura (Width), altura (Height), velocidad
T;‘f&”ﬂﬁl“?;'t"m (Fps=fotograma por segundo), color de fondo y orientacidon

del texto.

3. En el cuadro Text properties teclea el texto que deseas en la casilla Text.
En X e Y introduce las coordenadas en pixels de ubicacion del texto en la
pelicula. En Kern puedes definir la distancia entre caracteres. Elige la fuente
y tamafio en la lista desplegable correspondiente. También puedes definir el
color de la fuente, estilo y script del texto.
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4. En el cuadro Animation Properties (Propiedades de la animacion) puedes

®© N

elegir el efecto de texto que desees y configurar sus parametros en funcion
del tipo seleccionado.

En la ventana RoboFlash TextAnimator , selecciona File > Export movie
... (Archivo > Exportar pelicula ...) para crear el archivo SWF final que
contendra este texto animado.

En el cuadro de didlogo Save as que aparece, indica su nombre y ubicacion.
También puedes seleccionar algunas opciones como Fullscreen (pantalla
completa), Loop effect (efecto bucle), html (URL hacia donde se encamina
cuando el usuario hace clic sobre él), etc.

Pulsa el boton Guardar para concluir.

Mediante File > Save Animation As ... es posible guardar el proyecto de
animacion de texto definido en un archivo de extension *.RTS, especifico de
RoboFlash TextAnimator, para luego recuperarlo mediante File > Open
Animation ...

2. RoboFlash Splicer.

etc en un solo archivo SWF.

ﬁ Esta utilidad sirve para combinar archivos flash, imagenes, sonidos,

RoboFlash Splicer

1. Haz doble clic sobre el boton RoboFlash Splicer en la
consola general.
2. En el cuadro de didlogo Movie Properties (Propiedades de
pelicula) puedes definir la anchura (Width), altura (Height), velocidad
(Fps=fotograma por segundo), color de fondo, etc.
Utiliza la opcion File > Import File para importar a este proyecto
RoboFlash Splider, imagenes en formato .BMP, .JPG, etc.; sonidos en
formato .MP3; animaciones en formato .SWF, etc.
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4. Observa que todos los medios importados se situan en la ventana inferior.
Haz clic sobre uno para previsualizarlo bajo el logo de RoboFlash Splicer.

5. Para eliminar un medio, haz clic derecho sobre él y elige Remove
(Eliminar).

6. Pincha y arrastra un elemento para situarlo en la capa que desees (Layer).
Puedes superponer elementos, uno en cada capa.
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7. Para modificar los parametros de cada medio, haz doble clic sobre él en la
capa donde estd situado y se muestra el cuadro de didlogo Effect
Properties (Propiedades del efecto).

Effect Properties %

8. En la casilla Effect Name aparecera el
Effect Mame: | navegador swi

nombre del elemento multimedia

s Offaet 0 :l seleccionado. Introduce en X-Offset y
en Y-Offset las coordenadas en pixeles
T-Difset a —| del elemento dentro de la pelicula total.
Sk B3 :l 9. En la casilla Scale introducse el % de
- escala del objeto en la pelicula y en

Angle 0 :l Angle los grados de giro.
e - :l 10.En Fade puedes teclear el % de
= invisibilidad y en #Frames teclea el
o Frfies 200 :I nimero de fotogramas que durara ese

elemento.

11. Activa la casilla Sep effect until next
para mantener estos valores hasta el
proximo cambio de los mismos.

12.Si deseas previsualizar el resultado de tu combinacion, elige Window >
Preview o bien File > Test in Player.

13.Para crear el archivo SWF final, selecciona File > Export as SWF para
definir nombre y ubicacion del mismo.

Iv Keep effect until next.
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3. Ro

boFlash ScreenSaver.

Con esta utilidad puedes disefiar protectores de pantalla windows a

d partir de animaciones Flash SWF ya creadas.

.

1. Pulsa con doble clic en el boton RoboFlash Screensaver en la

roboFlash consola de RoboFlash.
SCreensaver 2. Arranca un asistente con un mensaje de bienvenida: Welcome

.... Pulsa en el boton Next > (Siguiente >)

RoboFlash Screensaver

i —

Enter the location of the Macromedia Flazsh file
that wou want bo convert to a screenzaver below.

C:ADocuments and Settingshddrministradori

[ Preview Options ] [ Settings ]
\j [ Advanced ]
[ Help ] [ < Back ][ Mewxt > %[ E xit ]

Clic en el icono de la carpeta para localizar el archivo .SWF original a partir
del cual se creara el protector de pantalla.
Pulsa el botén Preview Options (Opciones de previsualizacién) para definir
el aspecto de este protector en la ventana de previsualizacién en la solapa
Protector de Pantalla de la ventana Propiedades del escritorio de
Windows. Aqui puedes elegir un archivo BMP de tu equipo, si deseas que la
previsualizacion sea una imagen fija. Otra opcion es Use screensaver
movie as preview para usar la animaciéon del protector como
previsualizacién. Elige Use other Flash movie as preview (Usa otra
pelicula Flash como previsualizacién) para localizar una segunda animacion
en tu equipo. Para finalizar elige OK.
Clic en Settings (Configuracion) para definir el banner de Roboflash, una
imagen *.BMP y un enlace (Hyperlink) que se mostrara cuando el usuario
pulse el botén Configuracion en la ventana Propiedades del protector de
pantalla en Windows. OK para confirmar.
Clic en Advanced (Avanzado) y activa la casilla Create an interactive
screensaver para crear un protector interactivo y en la casilla Keep
Screensaver always on top (Mantener el protector de pantalla siempre
encima). Si activas estas dos opciones sera necesario que la animacién .SWF
original disponga de un botdn con la orden fscommand(“quit”) para cerrarlo.
Pulsa el boton Next para continuar.
En la casilla Enter the output directory ... haz clic en el icono de la
carpeta para definir nombre y ubicacion del archivo final instalador del
protector de pantalla.
Clic en el botdon Installer Messages para personalizar los mensajes que
mostrara el instalador al usuario:
e “This will install the screensaver. Continue?” : Esto instalara el protector
de pantalla. Continuar?.
e “The screensaver is installed.”: El protector de pantalla esta instalado.
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e “Error creating screensaver.”: Error creando el protector de pantalla.
e “Installing screensaver...”: Instalando el protector de pantalla...

RoboFlash Screensaver

Enter the output directory and file name of the
soreensaver installation progran;

[ C:ADocuments and SettingshAdministradorMis doc

[ Installer Meszages ]

[ Compress installation |:|r|:|g|r.5'|r|'|[}s

[ Help ][ < Back ][ Mewxt > ][ E xit ]

10. Clic en el boton OK del cuadro de mensajes del instalador y pulsa el botén
Next > .

11. Decide qué hara el instalador una vez que haya terminado:
e Do nothing: Nada.
e Open display properties: Abrir el cuadro de propiedades del escritorio.
e Start screensaver: Comenzar el protector de pantalla.
e Show readme file: Mostrar el archivo de texto Readme.

12.Clic en el botdn Next > y luego en el botén Finish para conluir. Al cabo de
unos instantes se generara el instalador del protector de pantalla. Clic en el
botén Test Now para probarlo ahora o bien en el boton Done para concluir
el proceso.

4. RoboFlash Protector.

Se utiliza para proteger a una aplicacion .SWF frente a la

= descompilacion y reutilizacion.
i 1. Doble clic en este botdn.
RoboFlash Pratectar 2. En la casilla Source file name and location , clic en el

botén Browse para localizar el archivo .SWF original.

3. En la casilla Protected output file name and location, pulsa el boton
Browse para definir el nombre y carpeta con que se guardara el archivo
final protegido.

4. Clic en el boton Protect (Proteger) para iniciar el proceso de creacion de
este archivo.

5. Si el proceso ha tenido éxito se mostrara el mensaje RoboFlash protector
has successfully generation ... (RoboFlash Protector ha creado con éxito
e)

6. Clic en Aceptar para concluir y a continuacion en el boton Close para
cerrar la aplicacién.
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5. RoboFlash Printer.

— Gracias a esta utilidad podras imprimir cualquier contenido o
— archivo en la impresora virtual de RoboFlash produciendo al final un
j archivo .SWF.
1. Doble clic en el boton RoboFlash Printer.
2. Desde el explorador de Windows, pincha, arrastra y suelta el
archivo que desees sobre la ventana de RoboFlash Printer. Otra opcion para
arrancar la impresora virtual es elegir Archivo > Imprimir desde la aplicacién con
que se ha creado este archivo (Word, Adobe, etc) y elegir como dispositivo de
impresion la impresora RoboFlash Printer.
3. En la ventana de visualizacién del documento en RoboFlash Printer
selecciona la opcién Save .Define nombre y ubicacién para el nuevo archivo
.SWF que contiene la imagen impresa de este documento.
4. Observa que en el SWF final, se afiade automaticamente una barra de
herramientas que facilita la navegacion entre las paginas en el .SWF
resultante.

RoboFlash Prinker

6. RoboFlash Extractor.

Esta aplicacion permite extraer los recursos: imagenes, sonidos,

e clips de pelicula, etc, a partir de un archivo SWF .
1. Doble clic en el boton RoboFlash Extractor.
2. En el cuadro Explorer haz clic para seleccionar la carpeta
RoboFlash Extractor

donde se encuentra el archivo *.SWF .
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3. En la columna inferior izquierda se muestran los archivo SWF que contiene
la carpeta seleccionada en el Explorer superior. Observa que al elegir un
archivo, su contenido se muestra en la ventana de previsualizacion.
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4. En el panel Resources situado en la columna derecha abre la carpeta del
recurso/s buscados: Shape (Formas), Sound (Sonidos), Font (Fuentes),
Text (Texto), Frame (Fotogramas) o ActionScript (Cdédigo de Script).

5. Selecciona una carpeta completa o varias. Dentro de una carpeta puedes
elegir un recurso o varios.

6. Para proceder a la extraccion, pulsa el botéon Extract situado en el
encabezado de la lista de recursos.

Extract Fesources §|

Path: File format
|D|:n:uments and SettingzsdministradorsE scitoio N - Shape:; |Mau:ru:umeu:|ia Flazh [* zwf]

= @' E zcritario Image |Image [*.ipg. * brp)
+ LD Miz documentos
+ j ki P Sound: |S|:uun-:| [*.waw, *.mp3]
* "—é Mis sitios de red Font; |Ma|:r|:|media Flazh [* zwf]
Test: |Mau:ru:umeu:|ia Flazh [*. zwf]

Sprite; | b acromedia Flazh [F swf]

Button: | Macromedia Flash [*. zwf)

Frame: |Ma|:r|:|media Flazh [* zwf]

Ll Ll Led Lol Lef Lef L] Lef Lo

Action;: |Te:-:t [* tt]

[v Usze 5w filename as the subdirectany

Eutract to;  C:A\Documents and 5 ettingz\adminiztradorsE seritoniot5 ampled

Mew Folder E =tract | Cancel Help

7. En la casilla Path navega para situarte en la carpeta donde desees que se
guarden los recursos extraidos.

8. En el panel File format podras definir el formato de los archivos finales.

9. Pulsa el boton New Folder para crear una nueva carpeta dentro de la
carpeta actualmente seleccionada.

10. Clic en el boton Extract para proceder y cierra la ventana de la aplicacion.

7. RoboFlash Converter for PowerPoint

Utiliza esta utilidad de RoboFlash para crear tus presentaciones

F en formato .SWF a partir de originales en formato .PPT disefiadas
LU con PowerPoint.
FoboFlash Comverker 1. Pulsa con doble clic sobre el icono de esta aplicacion.
For PowerPaink 2. En el cuadro de didlogo que se muestra, pulsa en el botén

Open PowerPoint (Abrir Powerpoint).
3. Se abrird la aplicacién PowerPoint de Microsoft.
4. Desde PowerPoint, abre la presentacion .PPT que desees. Aseglrate de que
se encuentra guardada en una carpeta de tu disco duro.
5. Pulsa el boton Convert to Flash situado bajo la barra de herramientas de
PowerPoint.
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6. En el cuadro de didlogo RoboFlash Converter for PowerPoint, pulsa en el
boton Properties para introducir los datos de la presentacion: Autor,
Company, Email, Website y Copyright. Estos se mostraran cuando el
usuario pulse el botén informacioén en la pelicula SWF final.

E RoboFlash Converter for PowerPoint

Convert to Flash™

1 T

Publishing Wizard
|Illllllll.‘

Prezentation name: Metodologia de la ensenanza con TIC. ppt
MHumber of slides: 9

Conwverzion Complete

Converting Shape 57 0% [NNNARNAARNARRNARNANR] 100%

Converting Slide

| Preview | |Saveasswr| | SaveasEXE |

[

E
FoboFlazh Converter for PowerPoint allovws wou to conwvert your
PowerPoint prezentations into Flazh files.

7. Clic en el botén Options (Opciones).

Built-in navigation

Metodolegia de |a avseianza con
TiE

Fly animation default:

v Show glide counter

Position: |Bu:|tt|:|m Right ﬂ

Choose Colors. ..
JPG quality

|T|:||:|

Load maovie [*.awf] at end:

j 100

Law High

k. Cancel |




Tutorial de RoboFlash Toolkit 2.0 9

10.

11

13.

14.

Activa la casilla Show navigation buttons para mostrar los botones de
navegacion que permitan navegar adelante/atras sobre las diapositivas. En
la lista Position puedes definir la posicidon de la botonera.

Si eliges la casilla Show slide counter se mostrard el contador de
diapositivas.

Arrastra el deslizador de JPG quality para definir la calidad de las imagenes
JPG en el SWF final.

. Pulsa OK para concluir.
12.

En el cuadro de didlogo RoboFlash Converter for PowerPoint, pulsa en el
botén Convert to Flash. Transcurridos unos segundos, se abrird una
ventana con el reproductor de Flash mostrando el SWF resultante final.
Cierra la ventana del reproductor de Flash y a continuacién en la ventana de
RoboFlash Converter pulsa el botdon Save as SWF para guardar el archivo
con un nombre y en una carpeta conocida.

Cierra la ventana de RoboFlash Converter.

E RoboF lash Converter for PowerPoint

B«" Properties Optionz | 4 Help J About

Prezentation name: Metodologia de la ensenanza con TIC ppt
MHurnber of glides: 9

Convert to Flash™
I'II..lllllll

Conwversion Complete

Converting Shape 57 0% [ENNNNNNNNNENNNNNNNN] 100%
Corverting Side 9 0% [INNNNANANNARNRRREENE] 100%

Publishing Wizard [ Preview | [Saveasswr| [Saveasixe |
T |>

a0
R oboFlash Comverter for PowerPaoint alloves pou to corsert your
PowerPoint presentations inta Flash files.




